pelican

Проблема с Альфа каналом в Вегасе

В теме 1 сообщение

Всем привет на этом форуме.

С виджейными делами только начинаю разбираться, так что заранее пардон, если вопрос ламерский.

Делаю футажи в вегасе с альфаканалом. В местах где прозрачность не 100%, в данные с цветом почему то попадает и фон.

Поясню на примере. Я хочу сделать полупрозрачный зелёный круг. Делаю маску, где сам круг белый, а фон чёрный.

182ef4a4772f.png

Накладываю её на однотонный зелёный фон (0:255:0), и сам слой заливки делаю прозрачным на 50%.

89716ce7580b.png

Получился зелёный кружок. В самом вегасе подкладываю под него чёрный фон - он тёмно зелёный, подкладываю белый - светло зелёный. Всё как надо.

a0f5bc51cd78.jpg7fab97c28bd8.jpg

А теперь я хочу этот кружок вывести в MOV с альфа каналом, чтоб можно было использовать в ArCaos.

Соответственно удаляю фон, и вывожу видео (Mov, без сжатия, 32 бита).

И вот что получаю на этом видео, если подсунуть белый и чёрный фон под него.

2b2e8d88c6e5.jpg15f9bad9aea6.jpg

Попробовал вывести в 32битный BMP. Альфа канал, как и должен быть - серый кружок на чёрном фоне. А сама картинка, вместо моей однотонной ярко-зелёной заливки - тёмно зелёный кружок.

Как-нибудь можно с этим бороться?

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти